How to upgrade the client to v3.1.0

Automatic updates won't work with this version increment. Please download and install the client on top of your current installation. The client plug-in version should be 3.1.0, this can be verified in Help/About/Installation details. Since we have replaced filters with criteria rules, all your real-time perspectives will be automatically converted to a new format. Just verify that conversion is correct before using the real-time views.

How to upgrade the server to v3.1.0

  • Stop logFaces server if running
  • If using archived distribution, unzip it over the current installation - your configuration settings will be safe. Verify that there is only single latest MongoDB driver in /lib/dbdrivers folder.
  • If using installer, let it handle the update. Don't register as service if you use the service wrapper.
  • Start logFaces server

Since we have replaced filters with criteria rules, the database filters, reports and triggers will be automatically converted to a new format. Please verify that conversion is correct before using the server by checking through admin pages.

Special note for MongoDB users - we have compacted the existing attribute names in order to save database space. All documents in your database will have to be converted in order to be accessible for queries. Download this script and run MongoDB shell like this: mongo convert-lfs31.js. The script presumes that you will run it on the machine where MongoDB is located. Note that large data storage will take some time to convert because script iterates through each entry in the collection. If you use indexes, make sure to rebuild them either from our admin page or directly using mongo console. If you don't want to do the conversion, you can just re-create database fresh.